Author Topic: AH maximized on screen when using Oculus  (Read 373 times)

Offline dBeav

  • Copper Member
  • **
  • Posts: 158
      • http://yankeeairmuseum.org
AH maximized on screen when using Oculus
« on: October 29, 2019, 05:20:28 PM »
I have found that when I put my Oculus headset on, AH will only play in a small window on my screen. I need to have it maximized for crowd viewing.
I have windows 10, Oculus Rift, and a Samsung TV using HDMI.
Any ideas?

Offline FLS

  • AH Training Corps
  • Plutonium Member
  • *******
  • Posts: 10963
      • Trainer's Website
Re: AH maximized on screen when using Oculus
« Reply #1 on: October 29, 2019, 05:27:22 PM »
It's a setting in AH VR preferences. Uncheck Disable Auto VR Mode Swap.

Offline dBeav

  • Copper Member
  • **
  • Posts: 158
      • http://yankeeairmuseum.org
Re: AH maximized on screen when using Oculus
« Reply #2 on: October 29, 2019, 05:28:13 PM »
Awesome, thanks!!

Offline Drano

  • Gold Member
  • *****
  • Posts: 3532
Re: AH maximized on screen when using Oculus
« Reply #3 on: October 29, 2019, 05:38:50 PM »
I was messing with that just the other day trying to get OBS to display right with my Rift S. I found you can just resize the AH window and make it fit in OBS. It's kind of an exercise tho and you'd have to do it every time you restarted AH if you wanted to stream. You can set Oculus mirror how you like it by setting up the shortcut with various commands and stream that. Much easier to deal with once you get it as you like. But you have both mirrors up on the monitor at the same time.

Sent from my Moto Z (2) using Tapatalk

"Drano"
80th FS "Headhunters"

S.A.P.P.- Secret Association Of P-38 Pilots (Lightning In A Bottle)

FSO flying with the 412th Friday Night Volunteer Group

Offline dBeav

  • Copper Member
  • **
  • Posts: 158
      • http://yankeeairmuseum.org
Re: AH maximized on screen when using Oculus
« Reply #4 on: October 29, 2019, 07:50:48 PM »
I'll have to play with more later. I think it works ok for my purpose but I still need to tweak the resolution or something to get it looking better on the screen.

« Last Edit: October 29, 2019, 08:13:53 PM by dBeav »

Offline Pluto

  • Copper Member
  • **
  • Posts: 337
Re: AH maximized on screen when using Oculus
« Reply #5 on: October 29, 2019, 11:43:20 PM »
You could try the oculus mirror. I've played around with it a bit, but can only get it to look so good.

Offline Drano

  • Gold Member
  • *****
  • Posts: 3532
Re: AH maximized on screen when using Oculus
« Reply #6 on: October 30, 2019, 05:31:59 AM »
Here's the link to how to set up oculus mirror.

https://developer.oculus.com/documentation/pcsdk/latest/concepts/dg-compositor-mirror/?locale=en_US

Sent from my Moto Z (2) using Tapatalk

"Drano"
80th FS "Headhunters"

S.A.P.P.- Secret Association Of P-38 Pilots (Lightning In A Bottle)

FSO flying with the 412th Friday Night Volunteer Group

Offline dBeav

  • Copper Member
  • **
  • Posts: 158
      • http://yankeeairmuseum.org
Re: AH maximized on screen when using Oculus
« Reply #7 on: October 30, 2019, 08:04:34 AM »
Thanks! Appreciate the help.

Offline Mister Fork

  • AvA Staff Member
  • Platinum Member
  • ******
  • Posts: 7117
Re: AH maximized on screen when using Oculus
« Reply #8 on: October 30, 2019, 10:29:31 AM »
I'll have to play with more later. I think it works ok for my purpose but I still need to tweak the resolution or something to get it looking better on the screen.

(Image removed from quote.)
Looks like a pretty slick room.  :x
« Last Edit: October 30, 2019, 10:41:24 AM by Mister Fork »
"Games are meant to be fun and fair but fighting a war is neither." - HiTech

"Unfortunately, this virus does not respect our feelings." - Dr. Deena Hinshaw on COVID-19

Offline dBeav

  • Copper Member
  • **
  • Posts: 158
      • http://yankeeairmuseum.org
Re: AH maximized on screen when using Oculus
« Reply #9 on: October 31, 2019, 06:08:06 PM »
I hate the paint job actually but my job was computers only.
The star of the show is an SBD Dauntless that was pulled from the bottom of Lake Michigan.

Offline SAAMIAM

  • Copper Member
  • **
  • Posts: 125
Re: AH maximized on screen when using Oculus
« Reply #10 on: November 18, 2019, 01:09:03 AM »
I use OBS as well.. when you set the OBS  to AH make sure you specify "Full Screen Applications" in OBS options. Also, make sure that the screen resolutions (ie 1366/720p or whatever your tv monitor is) match across the board, meaning in AH main menu "video settings" and in OBS video settings they all match.