Author Topic: Windows 10 won't sleep with joystick plugged in. Any solutions?  (Read 192 times)

Offline Brooke

  • Aces High CM Staff
  • Plutonium Member
  • *******
  • Posts: 13412
      • http://www.electraforge.com/brooke/
Re: Windows 10 won't sleep with joystick plugged in. Any solutions?
« Reply #15 on: January 29, 2020, 10:47:45 PM »
have you updated windows lately?
 mine did this also until the latest major update.
v 1903 had this problem for me, the current 1909 seems to work.

It's up to date.

Offline Ciaphas

  • Silver Member
  • ****
  • Posts: 1934
      • DethKlokDave
Windows 10 won't sleep with joystick plugged in. Any solutions?
« Reply #16 on: January 29, 2020, 10:53:48 PM »
As far as I know, my CH stick and pedals don't have any properties that I can set.  They are just HID devices in the Device Manager.  I have never installed any drivers or CH software for them.

Check your USB device settings.

go to control panel - hardware and sound - power options. Under preferred plan click on change plan settings.

Click change advanced power settings, expand USB settings, expand USB selective suspend settings and select disable from the drop down.

Reboot yer machine and see if that fixes it. If that doesn't can you confirm if this happens when any other USB controller is plugged in?


 



Sent from my iPhone using Tapatalk
10.(Jabo)/JG 26 Nuisance Raids Scenario


Offline FESS67

  • Silver Member
  • ****
  • Posts: 931
Re: Windows 10 won't sleep with joystick plugged in. Any solutions?
« Reply #17 on: January 30, 2020, 12:17:43 AM »
It's via powered hub.  I want my joystick and pedals into a powered hub, not direct into PC, though.

I understand that.  What I was suggesting is you TEST each configuration and if one does sleep and one does not you are closer to finding your root cause.  If neither sleep then you can tick that off as probably not a root cause.

Offline Brooke

  • Aces High CM Staff
  • Plutonium Member
  • *******
  • Posts: 13412
      • http://www.electraforge.com/brooke/
Re: Windows 10 won't sleep with joystick plugged in. Any solutions?
« Reply #18 on: January 30, 2020, 12:22:53 AM »
expand USB selective suspend settings and select disable from the drop down.

Reboot yer machine and see if that fixes it.

You, sir, are my hero.  That fixed it.  :aok

Thank you very, very much!


 



Sent from my iPhone using Tapatalk
[/quote]

Offline Ciaphas

  • Silver Member
  • ****
  • Posts: 1934
      • DethKlokDave
Re: Windows 10 won't sleep with joystick plugged in. Any solutions?
« Reply #19 on: January 30, 2020, 12:23:44 AM »
You, sir, are my hero.  That fixed it.  :aok

Thank you very, very much!


 



Sent from my iPhone using Tapatalk


You're welcome!

 :rock  :salute
10.(Jabo)/JG 26 Nuisance Raids Scenario